GS-Base Help > Opening and Saving dBase/FoxPro/Clipper Files

To Open an xBase File

Use the File > Open command and choose dBaseIII, dBaseIV, FoxPro 2.x or Clipper from the File of type list, or drag and drop a given xBase file into the main GS-Base window.
Next, specify additional xBase file options:

Encoding Specifies the text encoding for a given xBase file: ANSI 8-bit or ISO/OEM.

dBase/FoxPro/Clipper records marked as "deleted" are displayed with the "Selected" flag (the default "0" flag for each GS-Base database).

To Save an xBase File

Use the File > Save Recordset As command and choose dBaseIII, dBaseIV, FoxPro 2.x or Clipper from the File of type list.

Note: When saving an xBase file, GS-Base 14.5.3 and earlier versions save only filtered records from the active table, and GS-Base 14.7 and later versions save the whole table using the default (unsorted) record order. To save only the current filtered and sorted record set, you have to use the Save Recordset As command.

Records marked with the "Selected" flag (the default "0" flag for each GS-Base database) will be saved to dBase/FoxPro/Clipper databases as "deleted" records.

To automatically resize the column widths to fit the field contents in the opened file, select the Options > General > Auto-fit column widths in imported files option. Keep in mind that for very large files this may slow down the import process. To optimize the resizing, in the Options > General dialog box, increase the declared number of processor cores that GS-Base can use.

Related Topics

Saving PDF files
Opening and saving text files
Opening and saving HTML files
Opening and saving Excel workbooks