To Save a Database (or Just the Current Filtered Table) as an Excel Workbook
Use the File > Save Database Copy As or the File > Save Record Set As command and choose the Excel *.xlsx format or the Excel 97-2003 *.xls file format from the File of type list.
In the Save Excel File dialog box, specify the following options:
-
Split 64K+ row tables using name sequences
or
Split 1M+ row tables using name sequences
Tables with records exceeding the Excel row limit will be split into multiple Excel worksheets.
For example, if a database contains three tables "customers", "orders", "products" and the "orders" table has more than 1M/64K records, then the saved Excel file will contain the following worksheets:customers, orders, orders(1), orders(2), ..., products
-
Split 1M+ row tables into files using name sequences (for Excel *.xlsx files)
or
Split 64K+ row tables into files using name sequences (for Excel 97-2003 *.xls files)
If this option is selected, and if the number of records in one or more of the saved tables exceeds the Excel row limit, GS-Base will split such tables and save multiple Excel workbooks:
file_name.xlsx (or file_name.xls) file_name(1).xlsx (or file_name(1).xls) file_name(2).xlsx (or file_name(2).xls) ... file_name(n).xlsx (or file_name(n).xls)
If there are any previously saved files with larger indices (e.g. file_name(n+1).xls and on), they will be deleted.
If you open the file_name.xls file again in GS-Base, the remaining partial workbooks will be automatically (internally) loaded to form the original GS-Base tables. -
Save field names in the first row in all first worksheets
If this option and the 1st split option are selected, only the first worksheet from each split sequence will contain table field names in the first row.
If this option and the 2nd split option are selected, the first row in each worksheet in each split Excel workbook will contain the corresponding table field names.
-
Save field names in the first row in subsequent split worksheets
In addition to the above, worksheets that were split within one workbook will also contain that top row with table field names.
-
Enable restoring the GS-Base folder structure [...]
If this option is selected, and if you created folders in the GS-Base database explorer pane for some tables, the Excel sheet names will be formed as whole such table tree paths, which will enable GS-Base to re-create the original tree folder structure when you open the saved Excel *.xls workbook back in GS-Base.
As the "\" path separator cannot be used in Excel names, it's replaced with ">". -
Binary field options:
-
Save Long Text/Images/Files/Code fields to the zip file [...]
The contents of the above fields will be saved to the
file_name.gsb-bin.zip
file. You need to keep the saved Excel *.xls workbook(s) and that file together (in the same folder). The corresponding sheet cells in the *.xls workbook will contain links to objects in that zip. To access them, unzip it to the
file_name.gsb-bin
folder. Clicking a sheet cell formatted as a hyperlink (in GS-Base: Format > Hyperlink) will open the field contents (e.g. text, image or a folder with multiple images, etc.). You can edit/update/delete them and distribute your file_name.xls workbook either with the unzipped or zipped folder:
file_name.gsb-bin
-
Save only Long Text/Images/Files/Code field content description in sheet cells
The description includes the object names, number, total field size and recent modification date.
-
Note: After saving a document in a different format, you may need to use the File > Reload command to refresh the view.
To Open an Excel Workbook
Use the File > Open command (or alternatively any of the external table merging commands) and choose the Excel *.xlsx format or the Excel 97-2003 *.xls format from the File of type list.
In the Open Excel File dialog box, specify the following options:
-
Merge worksheets identified by name sequences
It's the reverse of the 1st split option in the above "Save" dialog box.
-
Merge all worksheets unconditionally
If this option is selected, all worksheets are assumed to be a sequence to be merged, regardless of their names.
-
Merge tables from previously split multiple Excel *.xls files [...]
See the mirror option described above in the "Save" dialog box.
-
Field names in the first row in all first worksheets
If this option is selected, the first row of the first worksheets from each merged sequence has to include the corresponding record field names.
-
Field names in the first row in subsequent split worksheets
In addition to the above, all worksheets in each merged worksheet sequence also has to include that top row with field names.
-
Restore the GS-Base tree structure [...]
See the mirror option described above in the "Save" dialog box.
Note: if subsequent worksheets in the same merged sequence have more columns, empty columns are added automatically to the preceding worksheets.