GS-Base Help > Spell-Checking and Adding Hunspell Dictionaries

Spell-Checking Availability

GS-Base 64-bit can use either the system spell checking functionality provided by Windows 8.x and later, or the Hunspell spell checking engine (available for all systems).
GS-Base 32-bit can use Hunspell spell checking only.
The current selection can be changed either in the Settings > Options > Spelling dialog box or directly in the Tools > Spelling dialog box.

Adding Hunspell Dictionaries

To install a Hunspell dictionary for a given language:

  1. Go to one of the websites which distribute Hunspell dictionaries, for example:

    https://addons.mozilla.org/en-US/firefox/language-tools/

    The dictionaries are distributed as zip files, typically with *.xpi or *.oxt extensions. After downloading the desired language file, rename it to a *.zip file.

  2. Each downloaded dictionary archive contains two text files with the *.aff and *.dic extensions and a name that (usually) represents the corresponding language ISO code, e.g. en-US.aff and en-US.dic (English US).

    Copy those files to some folder and specify that folder in the GS-Base spelling options. GS-Base will automatically find all installed Hunspell dictionaries and list them in the Spelling dialog box the next time you execute the Tools > Spelling command.
    To remove a given Hunspell dictionary, delete its *.aff and *.dic files from the above folder.

Adding Custom Words to Dictionaries

Users can add their own words to existing dictionaries (or, when using the Hunspell spell checking engine, create their own full dictionaries).
The added words are saved in a text file in a folder specified in the GS-Base spelling options. The file extension is *.txt, and the file name is the language ISO code corresponding to the dictionary the file is linked to. For example, if the dictionary files are

en-US.aff and en-US.dic

then the custom words will automatically (after closing the dialog box) be saved to

en-US.txt

New words are added by clicking the Add Word button when performing spell checking. The *.txt files can also be edited in any text editor to add a larger number of words at once.
The text files containing added words must be saved using UTF-8 encoding.

Other ISO codes include: